No internet connection
  1. Home
  2. Technical Support

Blank screen logging into BIOS.

By @chucky2021-05-22 15:24:16.821Z

I hooked up my Hobbyist kit to my Intel NUC NUC8BEH and when I try to enter the UEFI / BIOS, I get a blank screen.

Per this website, looks like there may be a resolution issue, Intel Help Page @ https://www.intel.com/content/www/us/en/support/articles/000005847/intel-nuc.html

If you're using an HDMI monitor or HDTV that doesn't support a resolution of 1024x768, you might not be able to access the Intel® Visual BIOS setup when pressing the F2 key.

I have the same problem when I hook up an old TV, but it works on my new HP monitor. I'll keep playing with it and see what happens.

Update-

I changed HDMI cables, same result, blank screen.

I rebooted, hit the key for BIOS, got blank screen of course, but then I unplugged the HDMI cable from the Tinypilot, plugged it into the monitor, still blank screen.

I unhooked the video cable from the Tinypilot and ran it to my monitor. I opened AnyDesk for viewing the screen and used the Tinypilot to control the keyboard mouse. I used Anydesk to reboot, opened the web browser with Tinypilot loaded and hit the BIOS key and I was able to get into the BIOS.

I then booted back into the BIOS(using monitor for video and Tinypilot for keyboard mouse) and then switched the cable from the monitor to the Tinypilot dongle and it was able to display the BIOS screen (odd) , when I rebooted and hit the key to get into the BIOS, same result, blank screen (Tinypilot for video keyboard and mouse).

  • 5 replies
  1. Michael Lynch @michael2021-05-24 20:07:02.828Z

    The Intel NUCs video output behaves a little strangely. Can you try entering this command and let me know if it allows you to capture video?

    readonly EDID="/home/ustreamer/edids/tc358743-edid.hex"
    echo -ne "" | sudo tee "${EDID}" && \
      echo '00ffffffffffff0052628888008888881c150103' | sudo tee -a "${EDID}" && \
      echo '800000780aee91a3544c99260f50542540000100' | sudo tee -a "${EDID}" && \
      echo '0100010001000100010001010101d51b00505000' | sudo tee -a "${EDID}" && \
      echo '19400820b80080001000001eec2c80a070381a40' | sudo tee -a "${EDID}" && \
      echo '3020350040442100001e000000fc0050492d4b56' | sudo tee -a "${EDID}" && \
      echo '4d20566964656f0a000000fd00323d0f2e0f0000' | sudo tee -a "${EDID}" && \
      echo '000000000000014d02030400de0d20a030581220' | sudo tee -a "${EDID}" && \
      echo '30203400f0b400000018e01500a0400016303020' | sudo tee -a "${EDID}" && \
      echo '3400000000000018b41400a050d0112030203500' | sudo tee -a "${EDID}" && \
      echo '80d810000018ab22a0a050841a3030203600b00e' | sudo tee -a "${EDID}" && \
      echo '1100001800000000000000000000000000000000' | sudo tee -a "${EDID}" && \
      echo '0000000000000000000000000000000000000000' | sudo tee -a "${EDID}" && \
      echo '00000000000000000000000000000045' | sudo tee -a "${EDID}" && \
      sudo v4l2-ctl --device=/dev/video0 --set-edid=file="${EDID}" --fix-edid-checksums
    

    TinyPilot will overwrite the EDID file whenever you update the software, so if you want to permanently use a custom EDID, run this command:

    sudo tee -a /home/tinypilot/settings.yml << EOF
    # EDID compatible with Intel NUC computers
    ustreamer_edid: |
      00ffffffffffff0052628888008888881c150103800000780aee91a3544c
      99260f505425400001000100010001000100010001010101d51b00505000
      19400820b80080001000001eec2c80a070381a403020350040442100001e
      000000fc0050492d4b564d20566964656f0a000000fd00323d0f2e0f0000
      000000000000014d02030400de0d20a03058122030203400f0b400000018
      e01500a04000163030203400000000000018b41400a050d0112030203500
      80d810000018ab22a0a050841a3030203600b00e11000018000000000000
      000000000000000000000000000000000000000000000000000000000000
      00000000000000000000000000000045
    EOF
    
    1. C@chucky2021-05-24 22:35:20.946Z

      Thank you for the reply! The only time I have to get to this is this weekend, I will give it a try and report back, thank you!

      1. In reply tomichael:
        C@chucky2021-05-27 00:36:45.632Z

        Hello, I copied and pasted the whole command you listed, and received the following error:

        tee: /home/ustreamer/edids/tc358743-edid.hex: No such file or directory

        1. Michael Lynch @michael2021-05-27 19:07:40.584Z

          Oh, sorry I missed that this was Hobbyist, which doesn't have the TC358743 (that's only for Voyagers).

          Unfortunately, I haven't heard of this behavior before on the Hobbyist, so I can't suggest any remediations. If this prevents you from using the Hobbyist kit for what you intended, I can take a return for a full refund.

          Sorry, I wish I had a better answer.

          1. C@chucky2021-05-29 20:44:26.803Z

            I pulled a Voyager off of my other server and with the code you provided was able to get it to work! I'll take you up on your offer for a return, and I'll purchase another Voyager to replace the Hobbyist. Thank you!