No internet connection
  1. Home
  2. Technical Support

Tinypilot opens on one pc but not other

By Hello IT @gmettn
    2023-11-06 15:44:51.416Z

    So the Tinypilot url accessibility is very random and it won’t connect forever on a system that it used to work fine yesterday.

    Sometimes, I would be able to access the url on one machine and not on another one.

    How do I have the url access issues solved for ever?

    • 14 replies
    1. David @david2023-11-07 12:00:57.907Z

      Hi @gmettn, I'm sorry you're running into this connection issue.

      Can I ask which browser you're experiencing this issue on? And have you tried different browsers?

      Have you also tried all three of the TinyPilot URLs (https://tinypilot, https://tinypilot.local, https://tinypilot.localdomain)?

      1. GHello IT @gmettn
          2023-11-07 15:51:58.309Z

          I have tried every url that you mentioned on system A, which used to work fine till 2 days ago.
          Edge and chrome are used. I always used the edge with no issues on system A.

          The same urls open on system B without any issues.

          1. David @david2023-11-08 12:21:32.214Z

            Thanks for that info, @gmettn!

            Since you can access your TinyPilot's web interface on System B, but not System A, this sounds like it could be a DNS caching issue or something similar.

            Could you try turning off your TinyPilot, System A, and your router? And then turn them all back on and see if you can access your TinyPilot again? I'm hoping that by doing that, your TinyPilot's network information will propagate through your network.

        • G
          In reply togmettn:
          Hello IT @gmettn
            2023-11-27 15:08:53.765Z

            The above issue is resolved. But I can’t successfully get the tiny pilot home page open everyday. It has issues 80% of the times and says page not found. I am trying to install the ca.crt but that page also shows page not found.

            I am loosing lot of valuable time. How do I get the timypilot homepage all the time successfully?
            Help me wit the crt. Pls.

            1. GHello IT @gmettn
                2023-11-27 15:12:32.651Z

                The error actually says - hmm can’t reach this page.

                1. GHello IT @gmettn
                    2023-11-27 16:20:23.745Z

                    That’s on edge browser. Similar error shows on chrome too.

                    I have tried with multiple laptops to access the Tinypilot in my local. Same issues.

                    I have 2 Tinypilot devices and have been using them since 6 months in the same network. And I made no changes to any of the settings.

                    I have initially renamed one tinypilot to https://aaa-bbb and other one is the default https://tinypilot. I have no other problems since 6 months but this one issue “hmmm.. page not found” occurs 80% of the times and I have to juggle all the connections and it works sometimes. But I want a solid connection every time to the Tinypilot homepage.

                    1. David @david2023-11-27 18:49:44.857Z

                      Hi @gmettn, I'm sorry you're running into this issue accessing the TinyPilot web interface on your devices.

                      Thanks for sharing those details!

                      Are you able to ping either of your devices?

                      On Windows you can run ping using CMD (press the Windows + R keys, type "cmd", then press Enter.). And via Terminal on Mac. Can you open CMD/Terminal, paste the following command, and hit Enter to run it?:

                      ping tinypilot.local

                      Can you let me know what ping's output is after using it to ping each of your TinyPilot devices?

                      1. GHello IT @gmettn
                          2023-11-27 19:05:25.392Z

                          It worked all of a sudden. I am seeing the ui and it’s all good. But still need the resin for the 4 hours delay.

                          1. David @david2023-11-28 11:43:03.160Z

                            Thanks for the update, @gmettn. I'm glad you were able to access the web interface in the end.

                            Unfortunately, it's difficult to provide a definitive reason why you were experiencing this issue. However, since your TinyPilot appears to be working correctly, this sounds like it could be an issue with the network you're using.

                            If you experience this issue again, can you try running using ping like in my previous response and show me ping's output?

                            1. GHello IT @gmettn
                                2023-11-28 15:51:20.760Z

                                Today I have the same issue with one tiny pilot. Here is the attachment of the ping.

                                1. GHello IT @gmettn
                                    2023-11-28 23:39:05.266Z

                                    I am trying to connect to the tinypilot from 2 laptops in the same network. One laptop pings and connects to the ui but a new laptop that’s in the same network won’t ping and won’t show the ui. Ping says could not find host.

                                    Also on both systems I have installed the ca.crt that I had once downloaded couple of months ago.

                                    What could be my troubleshooting?

                                    1. David @david2023-11-29 12:35:19.788Z

                                      Thanks for sharing that ping output. The output you've shown suggests that your TinyPilot is active on your network - so that's a great start.

                                      The one thing that stands out to me is that your TinyPilot uses an IPv6 address. This isn't normally an issue, but there's a chance your client machine(s) / network setup could be the source of the problem.

                                      When you reach the "Hmm... can't reach this page" message in your browser, can you share a screenshot with me? If there's a 'more details' section, can you expand that too so I can see what the exact message is?

                                      Also on both systems I have installed the ca.crt that I had once downloaded couple of months ago.

                                      I think we can ignore the ca.crt file for now. Installing the ca.crt on your browser fixes the privacy warning, so it shouldn't have an impact on actually connecting the TinyPilot web interface.

                                      1. GHello IT @gmettn
                                          2023-12-05 17:00:01.140Z
                                          1. David @david2023-12-06 13:00:50.188Z

                                            Thanks for sharing that photo.

                                            I'm a bit stumped on this issue. It looks like your browser or network is struggling to resolve your TinyPilot's hostname - but I don't know why.

                                            I believe Edge and Chrome use the same underlying technology. Could you try using a browser like Firefox to see if that resolves this issue?