No internet connection
  1. Home
  2. Technical Support

Cannot start usb-gadget service

By Marco @marco
    2023-11-13 08:01:48.686Zassigned to
    • @cghague


    I am using a RP4 with RaspiOS Bullseye lite (32-bit).
    For some unknown reason I am not able to create a HID device anymore (see error log).

    Report URL:

    Any idea what could be the reason for that?
    I flashed a new image a few times now and installed TinyPilot with the ''.

    I didn't use TinyPi for a few months until yesterday. I was just not able to use Keyboard and Mouse but could see an Image captured (HDMI Video Card). Now after flashing a fresh new image (multiple times) I'm neither able to see anything nor use keyboard and mouse.

    init-usb-gadget[532]: chmod: cannot access '/dev/hidg0': No such file or directory
    systemd[1]: usb-gadget.service: Main process exited, code=exited, status=1/FAILURE
    systemd[1]: usb-gadget.service: Failed with result 'exit-code'.
    systemd[1]: Failed to start Initialize USB gadgets.

    Thanks for helping out and best regards!

    • 3 replies
    1. M
      Marco @marco
        2023-11-14 08:23:47.669Z

        I replaced my Pi4 by a different one I had lying around.
        Surprisingly, it worked with it. Only the Pi4 was replaced - I still used exactly the same SD card and peripherals.
        So for me this problem is solved but I still wonder why it didn't work..

        1. Hi Marco, thank you for reaching out. I'm sorry to hear you're having issues with one of your Raspberry Pi devices.

          I don't believe we've seen an issue quite like this before, but given the same microSD card works in another device, and considering that you've tried a full re-flash, it does sound like the original Raspberry Pi may have developed a fault.

          The only time I've seen similar behavior was when one of my Raspberry Pi devices had problems maintaining a stable power supply, but there are no indications of this being the case in your logs. Is the new Raspberry Pi using the same power supply as the previous one?

          I appreciate it might sound unlikely to make a difference, but on the off-chance, have you tried switching the microSD card back into the original Raspberry Pi to check if it starts working again?

          1. MMarco @marco
              2023-11-15 15:26:11.965Z

              Hi Charles,
              thanks for answering!
              I used the exact same setup, also the same power supply.
              There was no indicator for an unstable power supply in the logs.

              So far, the "new" RP4 works also without any problems, so I also think that there is a fault with the previous RP4.
              I haven't tried to use it again, but I can still use it for a different purpose (Home Assistant) without problems.

              If I have new insights regarding this problem, I'll provide them here.

              Thank you and best regards!