No internet connection
  1. Home
  2. Technical Support

TinyPilot Pro Update Issues

By @pmcewan
    2024-01-09 17:05:08.421Zassigned to
    • @david

    I'm trying to update the Tiny Pilot Pro to the latest version - 2.5,4 and I get errors every time I try to do it:

    The update failed: Command '['sudo', '/opt/tinypilot-privileged/update']' returned non-zero exit status 2.

    Solved in post #2, click to view
    • 3 replies
    1. David @david2024-01-10 12:32:42.219Z

      Hi @pmcewan, I'm sorry you're running into this issue when updating to 2.5.4.

      This error sounds like this known issue when updating to 2.5.4.

      There are a couple of options to get around this issue.

      The easiest option is to re-flash your SD card with the very latest version of TinyPilot Pro (2.6.2). The latest version runs on top of a newer operating system and will continue to receive updates. The version you're currently running won't receive additional updates beyond 2.5.4 without re-flashing with the new operating system.

      Alternatively, there is a workaround you can use to update your system to 2.5.4:

      SSH into your TinyPilot and run the following commands:

      sudo apt-key adv --keyserver --recv-keys 0E98404D386FA1D9
      sudo apt-key adv --keyserver --recv-keys 6ED0E7B82643E131

      Then run the TinyPilot update on the TinyPilot web interface.

      I hope that helps! Please let me know if you have any other questions.

      1. P
        In reply topmcewan:
          2024-01-10 13:19:54.855Z

          That fixed it, thanks!

          1. David @david2024-01-10 14:58:24.797Z

            You're welcome! I'm glad you've been able to update.

            Please reach out again if you have any other questions.