No internet connection
  1. Home
  2. Technical Support

Failed to start Load EDID for TC358743 capture chip.

By @Raspberrykvm899
    2024-01-20 14:44:44.539Zassigned to
    • @david

    I have tried to follow the guide to setup my TinyPilot KVM using my Raspberry Pi 4 Model B 8GB.
    I purchased a USB HDMI capture device just like the one in this guide:

    I downloaded the recommended Raspberry Pi OS Lite Legacy file and created my micro SD card using the Raspberry Pi imaging tool with this downloaded img:

    I created the ssh file and I am able to ssh into the Raspberry Pi after setting up WiFi settings.

    I ran the tiny pilot install using this command:
    curl -sS
    | bash -
    sudo reboot

    Every time I boot, I receive the error Failed to start Load EDID for TC358743 HDMI capture chip.

    I verified that the adapter and HDMI cable work by plugging it into my Mac and capturing video from the Windows 10 and Windows 11 PC I have tried to connect to the Pi.

    I ran lsusb and the Pi sees the device as MacroSilicon USB Video.

    I thought it may be a power issue so I tried running the Pi from the power supply rather than USB 3 port on the computer and I still get the same error.

    I enabled video to external monitors on boot in the BIOS. I have tried setting the resolution to 1280x720 and still the same error and no video on the web interface.

    I tried to replace the EDID file using this guide:

    This is where I think the issue lies. The /home/ustreamer/edids/tc358743-edid.hex file did not exist on my setup. The edids directory did not exist. I tried creating both and changing the EDID and I receive the error VIDIOC_S_EDID: failed: Inappropriate ioctl for device.

    I am not sure if the original install failed or what could cause this. I reimaged the MicroSD card and tried running everything again to see if I missed something and I still receive the same error Failed to start Load EDID for TC358743 capture chip.

    Hoping someone has seen this and knows a fix.


    Solved in post #2, click to view
    • 2 replies
    1. David @david2024-01-22 15:56:49.123Z2024-01-24 12:59:27.222Z

      Hi @Raspberrykvm899, I'm sorry you're running into this issue installing TinyPilot on your device.

      Thanks for all those details!

      It sounds like your device is trying to capture an image from a TC358743 HDMI to CSI capture chip, rather than your HDMI to USB device. You shouldn't need to create or change any EDID files, since you're not using a TC358743 HDMI capture chip.

      Could you re-image your microSD card again with a clean image of Raspberry Pi OS Bullseye lite and run the latest simple install command from the TinyPilot README?:

      curl \
        --silent \
        --show-error \ | \
          bash - && \
        sudo reboot

      Once the command finishes installing TinyPilot, you won't need to run any additional configuration steps, since you're using an HDMI to USB device.

      I hope that helps! Please let me know if you have any questions.

      1. R@Raspberrykvm899
          2024-01-22 18:05:36.482Z

          Thank you so much David. After running the install, I still get the error but as you said that service isn't needed and now I receive video through the Tinypilot web interface. Thank you so much for your help.
          I can't wait to start testing the capabilities.