No internet connection
  1. Home
  2. Technical Support

Mouse and keyboard is not working after macOs upgrade Sonoma 14.4

By @tyler.boyette
    2024-03-11 17:35:21.477Zassigned to
    • @david

    After OS upgrade, mouse and keyboard using tinypilot is not working.
    Can you please help me on this?

    Solved in post #12, click to view
    • 13 replies
    1. T
      In reply totyler.boyette:
        2024-03-11 18:11:02.824Z

        @cghague, Do you have any idea on this?

        1. In reply totyler.boyette:
          David @david2024-03-11 19:10:31.097Z

          Hi @tyler.boyette, I'm sorry you're running into this mouse and keyboard issue.

          Thanks for those logs! There's nothing in the logs that point to an obvious issue or cause, but they do show that your TinyPilot can't send USB input to your target machine.

          Just to confirm, this issue started after updating the Mac to 14.4?

          Are you able to disconnect and then reconnect the TinyPilot data cable that connects to your Mac? I'm wondering whether your Mac didn't re-establish its USB connection after it updated.

          1. T
            In reply totyler.boyette:
              2024-03-11 19:15:32.373Z

              Yes, after 14.4 upgrade, it's not working. i disconnected and reconnected data cable to mac again after upgrade.

              1. T
                In reply totyler.boyette:
                  2024-03-12 00:00:29.765Z
                  1. T
                    In reply totyler.boyette:
                      2024-03-12 10:49:31.980Z

                      I tried to use another tinypilot but mouse and keyboard are still not working. I disconnected cables and reconnected them but screen is coming and mouse, keyboard are not working.

                      1. David @david2024-03-12 11:50:33.700Z

                        Thanks for those updates, @tyler.boyette.

                        All of those subsequent logs continue to show the same USB input issue. Since both TinyPilot devices seem to be running as normal, but have this input issue, it sounds like the problem could be the Mac or the connection between the TinyPilot and the Mac.

                        Can you tell me whether you're using an adapter to connect your TinyPilot to your Mac (i.e., USB-A to USB-C)?

                        Do you have any alternative devices you could connect to your Mac to test whether they work correctly (with the adapter if you're using one)? For example, a USB mouse, USB keyboard, or a USB drive?

                      2. T
                        In reply totyler.boyette:
                          2024-03-12 12:26:01.740Z

                          Hi @david , Thanks for your update.
                          I am using adapter to connect tiniypilot to mac. I didn't test usb drive for mac. I will try and let you know.


                          1. T
                            In reply totyler.boyette:
                              2024-03-12 12:49:40.739Z

                              @david I used usb drive and it's working on mac.

                              1. David @david2024-03-12 15:05:09.593Z

                                Great, thanks! That test suggests that the adapter is working as expected.

                                Can you try the following steps and see if that triggers your Mac to recognize your TinyPilot?

                                • Disconnect your TinyPilot and adapter from your Mac.
                                • Completely disconnect your TinyPilot's data cable on both ends.
                                • On your Mac, go to Settings > Privacy & Security > Allow accessories to connect.
                                  • Change the behavior to "Ask every time".
                                • Restart your Mac.
                                • Connect your TinyPilot's data cable to the Mac via the adapter.
                                • Connect your TinyPilot's data cable to the 'DATA' port on the TinyPilot.

                                I'm hoping that if you follow those steps directly, you should see a pop-up on your Mac asking to approve the USB device (in this case, your TinyPilot).

                                Can you run through those steps and let me know if that works for you?

                                1. T@tyler.boyette
                                    2024-03-12 21:00:01.739Z

                                    I tried and it's working now. thanks

                                    1. David @david2024-03-13 11:55:41.629Z

                                      You're welcome! I'm glad you're back up and running!

                                2. T
                                  In reply totyler.boyette:
                                    2024-03-12 13:07:49.022Z

                                    I used usb adapter for USB drive on mac.