No internet connection
  1. Home
  2. Technical Support

TinyPilot returns 404 after update

By @herbdierks
    2024-03-14 02:29:54.890Zassigned to
    • @cghague

    I can still get into the device via SSH, but the web interface is only returning a 404 screen.

    I have tried restarting the tinypilot service vis SSH, which didn't help. Reboot doesn't help either.

    Checking the tinypilot service status via SSH several times in a row, it appears that the service is starting and stopping on its own.

    What should I do?

    Solved in post #5, click to view
    • 5 replies
    1. @fft2024-03-14 08:18:34.547Z

      I personally would do a factory reset

      if the TinyPilot is accessable for you.


      1. In reply toherbdierks:
        David @david2024-03-14 12:05:00.317Z

        Hi @herbdierks, I'm sorry you're running into this 404 issue.

        Typically, this issue points towards filesystem corruption on your SD card (likely because of missing files). Like Juergen mentioned, a factory reset is the quickest way to get back up and running.

        If you'd like, I can review a TinyPilot log to see if there's anything else that could be causing this issue. Could you connect to your TinyPilot via ssh and run the following command to generate a log and a sharable URL:

        sudo /opt/tinypilot-privileged/collect-debug-logs

        Please let me know if you have any questions.

        1. H@herbdierks
            2024-03-14 14:37:27.026Z

            Log files here:

            The device is in a data center, so I'm trying to repair this remotely if possible.

            On the TinyPilot image download page, I tried Option 2 (running "curl -L | sh") which didn't help. At the end of the script it said that it didn't find anything to update:

            0 upgraded, 0 newly installed, 0 to remove and 90 not upgraded.

            Anything else I can try remotely? Or is my next move driving out to the data center to flash the microSD?

            I appreciate the quick response - and really like the TinyPilot, other than this little hiccup!

            1. Hi @herbdierks, thanks for getting back to us!

              I've reviewed the logs and see that part of the TinyPilot installation is missing from your device. You may be able to force a complete reinstallation by running the following command to thoroughly purge the old installation before trying to reinstall again:

              sudo apt --purge remove tinypilot

              Unfortunately, even if this works, there may still be corruption in other locations on the microSD card, so I recommend performing a factory reset as soon as possible. I appreciate this is a hassle, so you may want to consider enabling the read-only filesystem after the reset, as that drastically reduces the chances of corruption occurring.

              1. H@herbdierks
                  2024-03-15 00:27:20.980Z

                  That worked! Thank you so much!

                  The next time I'm in the data center, I'll plan on flashing to SD card for good measure. Thanks for the quick and helpful response!