No internet connection
  1. Home
  2. Technical Support

Unable to use Keyboard or mouse on tinypilot from remote side

By Naveed Sheikh @naveednizam
    2024-03-15 16:18:17.475Zassigned to
    • @cghague

    I have my work laptop connected to tinypilot, Which I access from home sometimes to do emergency tasks. But I am unable to use my keyboard and mouse from remote side now. I have tried searching for the issue and it's solution but I cannot find any solution to it. What could be the issue and how to resolve it?

    Solved in post #4, click to view
    • 9 replies
    1. C

      Hi Naveed, thanks for your message. I'm sorry you're having issues using the keyboard and mouse.

      I'd be happy to help you investigate and resolve this problem. As a starting point, can you please send me a link to your debug logs? You can do this by going to System, then Logs, then Get Shareable URL.

      1. NNaveed Sheikh @naveednizam
          2024-03-18 14:01:27.271Z

          Hi Charles,

          I cannot find any logs or options to share link there in System>Logs. Please see the screenshot attached. What should I do now?

          1. Thanks for getting back to me and for providing the helpful screenshot!

            Unfortunately, your TinyPilot device's inability to display its logs suggests it might have a corrupted filesystem. The most common causes of filesystem corruption are large amounts of disk activity or unexpected power failures.

            Can you please try a factory reset? I appreciate it's a hassle, so you may want to consider turning on the read-only filesystem after the reset is complete, as it will drastically reduce the chances of corruption occurring.

            1. NNaveed Sheikh @naveednizam
                2024-03-19 12:43:21.893Z

                Do I need TinypilotPro license for keyboard and mouse to work?
                When I tried to download the image to flash the sd-card from the link provided, it says my license expired few months ago.

                1. Thanks for getting back to me so quickly.

                  You can purchase a new 1-year license from our website. The license gives you access to TinyPilot's latest features and bugfixes and priority support for one year.

                  As a small company, we rely on license renewals to help fund our software development, so thank you in advance if you choose to renew!

                  If you'd rather not renew, I can email you a link to the latest version of TinyPilot Pro that you qualify for.

                  Please let me know how you'd like to proceed.

                  1. NNaveed Sheikh @naveednizam
                      2024-03-19 17:58:33.762Z

                      I am not against renewing my license, but first I would like to fix my problem, and if the issue is resolved, I can go for renewal as it's not very costly. But, I would like if you could first send me the link for the available version on my account? I can try flashing the card and see if the issue is resolved, and i'll let you know.

                      1. Thanks for the quick response! I've asked our customer support team to send you a link to the latest version you're eligible for. You should hear from them soon.

                        1. NNaveed Sheikh @naveednizam
                            2024-03-20 13:20:00.146Z

                            Hi charles, thanks for the url. I have flashed the image, but the tinypilot showed for 30 seconds and the mouse keyboard was not working as well. But once I checked the logs, it stopped working and shows error, the link for logs is:

                            as for the current state of tinypilot even after restarting is this error I have shared screenshot below

                            1. NNaveed Sheikh @naveednizam
                                2024-03-20 13:24:21.732Z

                                Nvm, I think the issue was temporary as the tinypilot started working again. If the issue starts again, i'll create another ticket.

                                Thanks for your time. The issue is resolved now.