No internet connection
  1. Home
  2. Technical Support

Updating and VGA adapter issues

By @brandon.metroswitch
    2024-03-28 18:43:59.280Zassigned to
    • @david

    I just installed my TinyPilot and have access to it on my network. However, I am not able to set the IP address as there is no "Network" tab in the menu. I am also unable to perform an update. I keep getting this error:

    Error: Failed to request latest available version: <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: certificate is not yet valid (_ssl.c:1123)>

    The last thing is that we also purchased the VGA to HDMI adapter and the display keeps flashing on and off until it finally just displays nothing. The VGA port has been verified as working by using a standard VGA cable to a monitor.

    Did we get a lemon Tiny Pilot, or are there fixes for these issues.

    Thank you,


    Solved in post #5, click to view
    • 5 replies
    1. David @david2024-03-29 13:00:25.084Z

      Hi Brandon, I'm sorry you're running into a few issues with your TinyPilot.

      And thanks for sharing all those details.

      We only recently added the "Network" item in TinyPilot's web interface, so it may be that your TinyPilot device is running an older version of the TinyPilot software.

      The error you're receiving when attempting to update, certificate is not yet valid, suggests that the time on your TinyPilot is incorrect. This usually happens if your TinyPilot can't re-sync its time with an NTP server.

      My recommendation here is to perform a factory reset to simultaneously bring your TinyPilot's software to the latest version (2.6.3) and allow you to set a static IP via the "Network" menu. Once your TinyPilot has Internet access, it should be able to sync its time again, resolving the certificate validation error.

      As for the VGA adapter/display issue, do you happen to know what resolution and frame rate your target machine normally outputs at?

      Please let me know if you have any questions, or if there's anything I can clarify.

      1. B@brandon.metroswitch
          2024-03-29 17:33:24.784Z

          Hi David, thank you for your response.

          I was able to go the SSH route and set a static IP that way. We now have full remote access to the Tiny Pilot on our network.

          We had also already tried lowering the resolution and frame rate on the Tiny Pilot and the display was still flashing on and off and eventually just stays off. We ended up purchasing another VGA adapter and it ended up working on our machine, but it does work much better after lowering the resolution and frame rate.

          As far as the updating issue, we still are getting the same error. Now knowing how to get everything working, we will try your suggestion of factory resetting the Tiny Pilot and hopefully re-syncing it to the NTP server.

          Thank you again for your help, once the Tiny Pilot is up and running properly we do very much like this product. Hopefully we will be able to resolve the updating issue.


          1. David @david2024-03-29 19:12:46.358Z

            Thanks for the update! I'm glad you're up and running with the network and display!

            If you haven't already tried a factory reset, another option is to re-sync TinyPilot's clock with a command via SSH.

            To do this, SSH into your TinyPilot, and run the following command:

            sudo timedatectl set-ntp true

            Then confirm the date and time are correct with this command:


            If the date and time time are now correct, can you try updating your TinyPilot via its web interface (System > Update)?

            1. B@brandon.metroswitch
                2024-03-29 23:03:52.916Z

                The command you provided did not work for us but most likely because we are using a public NTP server. However it did help us in figuring out what needed to be set. We ended up using commands:

                timedatectl set-ntp 1
                timedatectl set-timezone America/Los_Angeles

                After a reboot we were then able to perform the update and everything is working great. We even have the "Networking" tab in the system menu now.

                Thank you for your help in resolving this issue.

                1. David @david2024-04-01 11:15:58.667Z

                  Thanks for the update, Brandon! You're welcome - I'm glad you're now up and running.

                  Feel free to reach out again if you have any questions.