No internet connection
  1. Home
  2. General

TinyPilot Voayger current version?

By @ComputerDoktor2021-06-09 10:05:53.846Z

It seems that TinyPilot Voyager we received had version 2.2.2-beta1
Update installed a downgrade? to 2.2.1.
Which version is recommended?

  • 3 replies
  1. Michael Lynch @michael2021-06-09 18:21:15.463Z

    Hmm, this is strange. I'm not sure how 2.2.2-beta1 could have shipped on a Voyager order. Was this for an order that shipped in early May? I didn't build the 2.2.2-beta1 image until May 28th, so it doesn't seem possible that an early May order could have shipped with that version pre-loaded.

    How did you determine that the device was running 2.2.2-beta1?

    2.2.1 is the latest released version, so if you're running 2.2.1, that's the correct version. 2.2.2 will likely come out next week.

    1. C
      In reply toComputerDoktor:
      @ComputerDoktor2021-06-10 04:58:34.121Z

      Ok. I have sent the tinypilot-updater journal via email to you.

      1. In reply toComputerDoktor:
        Michael Lynch @michael2021-06-11 16:05:47.231Z

        Ah! I think I figured out what happened here.

        When TinyPilot updates, it's supposed to only update to release versions (e.g. 1.2.3) and ignore pre-release versions (1.2.3-beta1).

        TinyPilot Pro 2.2.0 and below had a bug where it would update to a pre-release version if it was formatted with a dash. I fixed that bug in 2.2.1, but I forgot that old versions had that when I created the 2.2.2 beta.

        So what I think happened was:

        1. Your Voyager arrived with 2.2.0 installed
        2. You updated and got 2.2.2-beta1 due to the update bug
        3. You updated again, and your 2.2.2-beta1 system saw 2.2.1 as the latest release version and "upgraded" to it even though it's really a downgrade
        4. With 2.2.1, the bug was fixed, so it saw 2.2.1 as the latest version and didn't offer any updates.

        I'm going to publish the final 2.2.2 release on Monday or Tuesday, so that should fix this issue for any versions on 2.2.0 or below that try to update. The 2.2.0 and below version uses the semver package, which sees 2.2.2-beta1 as lower than 2.2.2.