No internet connection
  1. Home
  2. Technical Support

TinyPilot Voyager - No Signal - Persistent device timeout (unplugged)

By @helloworld
    2022-04-15 00:08:24.499Z

    Hello,

    I am using the TinyPilot Voyager with the VGA to HDMI adapter provided. Based on the logs it seems that it never detects my device. I've tried two different VGA to HDMI adapters. The server is outputting to a splitter with one side going to a monitor (works fine) and the other to the HDMI adapter into the TinyPilot.

    Apr 14 19:48:43 tinypilot ustreamer[562]: -- INFO  [22.974    stream] -- Device fd=9 opened
    Apr 14 19:48:43 tinypilot ustreamer[562]: -- INFO  [22.974    stream] -- Using input channel: 0
    Apr 14 19:48:43 tinypilot ustreamer[562]: -- INFO  [23.001    stream] -- Using resolution: 640x480
    Apr 14 19:48:43 tinypilot ustreamer[562]: -- INFO  [23.001    stream] -- Using pixelformat: UYVY
    Apr 14 19:48:43 tinypilot ustreamer[562]: -- INFO  [23.001    stream] -- Querying HW FPS changing is not supported
    Apr 14 19:48:43 tinypilot ustreamer[562]: -- INFO  [23.001    stream] -- Using IO method: MMAP
    Apr 14 19:48:43 tinypilot ustreamer[562]: -- INFO  [23.005    stream] -- Requested 5 device buffers, got 5
    Apr 14 19:48:43 tinypilot ustreamer[562]: -- INFO  [23.012    stream] -- Capturing started
    Apr 14 19:48:43 tinypilot ustreamer[562]: -- INFO  [23.012    stream] -- Initializing OMX encoder ...
    Apr 14 19:48:43 tinypilot ustreamer[562]: -- INFO  [23.015    stream] -- Initializing OMX encoder ...
    Apr 14 19:48:43 tinypilot ustreamer[562]: -- INFO  [23.016    stream] -- Initializing OMX encoder ...
    Apr 14 19:48:43 tinypilot ustreamer[562]: -- INFO  [23.026    stream] -- Using JPEG quality: 80%
    Apr 14 19:48:43 tinypilot ustreamer[562]: -- INFO  [23.026    stream] -- Creating pool JPEG with 3 workers ...
    Apr 14 19:48:43 tinypilot ustreamer[562]: -- INFO  [23.026    stream] -- Capturing ...
    Apr 14 19:48:44 tinypilot ustreamer[562]: -- ERROR [24.027    stream] -- Persistent device timeout (unplugged)
    

    In addition I have tried the EDID change suggested here with no difference: NO SIGNAL but keyboard and mouse are working #post-16

    The resolution is fixed at 640x480, it's outputting a terminal over VGA. Any thoughts?

    • 5 replies
    1. D
      Diego @diego2022-04-15 15:09:34.300Z

      Hello @helloworld! First of all, I'm sorry you are having this issue.

      • Please try a direct connection to the TinyPilot, without the splitter in between in order to rule out this is not a splitter issue.

      • The VGA to HDMI adapters need to be USB powered, please ensure you are trying with one of those.

      • The problem might be the HDMI cable. I have seen it happening before, with same error. Please try with a different high-quality HDMI cable.

      1. H
        In reply tohelloworld:
        @helloworld
          2022-04-16 04:50:04.868Z

          Do you have any known cables and/or splitters you can recommend? The location where I installed it is a bit far and I won't be there until next week, so will try to bring some solutions with me to avoid having to do another trip, thanks!

          1. DDiego @diego2022-04-18 17:02:03.026Z

            Hi @helloworld

            We don’t have any splitters or cables that we officially recommend.

            However we’ve tested this HDMI splitter successfully with TinyPilot:

            https://www.amazon.com/gp/product/B005HXFARS/

            StarTech brand HDMI splitters likely have wider compatibility, but we haven’t tested it with TinyPilot:

            https://www.startech.com/en-us/audio-video-products/st122hd202

            1. H@helloworld
                2022-04-18 17:36:56.610Z

                Thanks Diego. Do you know regarding HDMI cables? At the moment the server is just a VGA output to a VGA monitor and i'm using the VGA->HDMI adapter from your store that came with the tinypilot. So it sounds like it might be the cable, since I imagine thats a known working adapter which you are selling. I'm going to try to do your other recommendation of testing it directly without the VGA splitter as well once I go there, just trying to order a handful of potential solutions and I can just return the ones that don't work out.

                Thanks

                1. DDiego @diego2022-04-19 16:37:11.346Z

                  Hi @helloworld

                  Regarding HDMI cables, most brands should work. We use Cable Matters brand, you might want to use the same:

                  https://www.amazon.com/Cable-Matters-3-Pack-Resolution-Support/dp/B00P2PQBCY