No internet connection
  1. Home
  2. Technical Support

TinyPilot Voyager 2 just quit working

By Daniel Smith @danbridge
    2022-09-19 19:55:58.915Z

    I have been successfully using (and loving) my TinyPilot Voyager 2 for a while now and all of a sudden, I am not able to access it. I have tried to ping it with no response. I followed steps in: TinyPilot not getting an IP address? without success. I have the POE version, the lights light up, the power light is red, the drive activity light is flashing green. I tried swapping ethernet cable/poe port with another working device. I tried replacing the microSD with another base image and still not seeing it pickup an IP address (I have a reservation for the MAC of the TinyPilot that has been working since day 1). Based on the list of suggestions, it appears the TinyPilot hardware may be faulty? Any other suggested steps I can take?

    • 4 replies
    1. David @david2022-09-21 18:33:26.183Z

      Hi @danbridge, sorry about your connection issues. And thanks for detailing what you've already tried.

      Any other suggested steps I can take?

      Is it possible to remove the IP reservation for the TinyPilot's MAC address? Or maybe to try your TinyPilot with a different router? I'd like to see whether your TinyPilot can grab any IP address at all.

      1. DDaniel Smith @danbridge
          2022-09-21 20:30:10.317Z

          Hi as it turns out the second microSD card i had was bad so i got a new one and imaged it with lite os and now the TinyPilot is getting an IP as expected! So i guess i am in same boat as the others where the TinyPilot image is corrupt. How can I get a new image? I have the PRO license.

          1. DDaniel Smith @danbridge
              2022-09-21 20:50:41.019Z

              Actually i found the download page where i can plug in my order number etc and got the image downloaded. However, i have tried to write image using Etcher with 2 different MicroSD cards multiple times on multiple USB ports and they all fail at the very end of verification. How do I troubleshoot this situation?

              1. David @david2022-09-22 12:40:05.501Z

                Glad you found the download page!

                Validation issues tend to stem from bad SD cards. However, before suggesting that you get a brand new SD card, we can try a couple of things.

                Do you have a different microSD USB writer that you could use? It's not a problem if you don't, but it's worth a try if you do.

                Instead of using balenaEtcher, could you try a different piece of software (like Rufus) to flash the drive? There may be an issue with the balenaEtcher software causing the error.

                If they both fail to solve the issue, you may need a new microSD card.