No internet connection
  1. Home
  2. Technical Support

Tinypilot data port not working - cant connect to keyboard and mouse

By @techie
    2023-03-09 15:54:19.461Zassigned to
    • @cghague

    My tinypilot 2's data port is no longer working.

    I have tried everything I could think of. I switched wires to wires that work on my other tinypilots (I have 3 others). Cross tested the laptops with the other tinypilots and they seem to work.

    The video port works but the data port doesnt. Is there anything I could do to get it exchanged or something I can run that would magically make the data port run?

    • 9 replies
    1. C

      Hi @techie, thanks for reaching out to us. I’m sorry to hear your data port has stopped working. This could be due to either a hardware or software issue so we’ll need to investigate. It sounds like you’ve already ruled out any external hardware issues, so, for the next step, could you please share a link to your debug logs by going to System, then Logs and then Get Sharable URL?

      1. T@techie
          2023-03-09 18:29:32.948Z

          Thank you for your reply! Yes here it is:

          1. Thanks for sharing your logs! It does look like there is an issue outputting data over USB but the cause isn’t clear. I’d normally recommend re-installing TinyPilot Pro and/or performing a factory reset at this point, but as you have multiple devices there may be an easier option. Would you be able to shutdown the affected device and one of the working devices, swap the microSD cards around, and then power the two devices back up? If the issue moves to the other device then it is a software issue but if the issue stays on the same device then it is likely to be a hardware fault.

            1. T@techie
                2023-03-13 17:51:45.410Z

                Hey @cghague ,

                Apologies for the delays, I didn't realize I got a response.

                That was a brilliant suggestion. I have swapped the cards as you mentioned and booted up the TinyPilot. Unfortunately i'm still having the same error. Video feed is fine, but my mouse and keyboard are still not working.

                Does it look like we ruled out a software issue and that it's more of a hardware issue? If so, what else can we do? I'm going out of town next Monday and really need this solutions working :(

          2. C
            In reply totechie:

            Thanks for getting back to me!

            My understanding is that TinyPilot A couldn’t control any computer it was connected to whereas TinyPilot B could control all of the same computers. This was also the case even after swapping the USB cables. You’ve now swapped the microSD cards around, and TinyPilot A (now containing the microSD card from TinyPilot B) still can’t control any computer, whereas TinyPilot B (now containing the microSD card from TinyPilot A) can still control all of the same computers.

            Can you please confirm if that’s correct? If so, it does sound like a hardware fault unfortunately. It might be worth checking the USB-C port is completely free of obstructions as USB-C ports are particularly susceptible to dust, but if not then the affected device will need repair. Once you’ve confirmed the above I’ll ask for our customer support team to reach out by email to discuss what options are available.

            1. SSven Hurter @Sven
                2023-03-14 15:49:11.006Z

                Hi Charles, as i facing in the same issue i would join in this case. I have bought 4 new devices and all of them are facing the same issue. If it is a hardware issue, please get in contact with me also. Kindly regards - Sven

                1. Thanks for reaching out to us! I’ve reviewed the thread you posted and it doesn’t seem like the same hardware issue. I’ve replied on your thread with the next steps in the investigation. Let’s continue the discussion on the other thread as the separation helps to keep everything organized and manageable.

                2. In reply tocghague:
                    2023-03-14 18:56:23.962Z

                    Hey @cghague - Yep that's correct. I have tried every variation of cables/sdcards/power cables and Tinypilot A simply cannot control any of the devices. USB port is free from any obstructions. let me know what we can do!

                    1. Thanks for confirming and for going through the troubleshooting process with me. As this appears to be a hardware fault I’ve asked our customer support team to reach out to you by e-mail to discuss what options might be available.