No internet connection
  1. Home
  2. General

Having problems with KVM Switch and TinyPilot

By @jtca2021-05-26 12:32:22.419Z

Hi. I am trying to get the Voyager to work with a KVM Switch. I have 5 Dell PowerEdge servers I am trying to use the Voyager with.

I originally tried with the IOGear 1808. I saw this thread Keyboard + Mouse do not work and was hoping I could get the setup working for me. However I was never able to get the display or the keyboard/mouse to work.

So I bought an 8 port E-SDS that I saw had full compatibility on the wiki. I connected the servers to the KVM switch HDMI having to use powered VGA adapters because the servers only have VGA. I bought the same adapter that comes with the Voyager kit for each of the servers. The servers are plugged into inputs 4-8 on the KVM switch. I can get full functionality on port 4 (Video + keyboard/mouse). But I cannot get video on any other input. I can switch inputs via the keyboard shortcuts but when I switch to input 5-8 I only get No Signal.

Oh I also bought the powered splitter you recommended here: Newbie Problems / Questions and have it between the KVM Switch and the Voyager.

I have tested the KVM switch with a monitor and keyboard/mouse to make sure it works and it does with all inputs.

Any thoughts on things I can try to get this to work.

  • 8 replies
  1. Michael Lynch @michael2021-05-27 21:21:42.966Z

    Thanks for reporting this. Sorry to hear you're running into issues with this setup. I haven't tested the E-SDS KVM personally, but I received a report from a user that it worked.

    That's strange that only port 4 works. Can you think of anything that's special about port 4 on the KVM?

    Have you tried it without the powered HDMI splitter? The powered splitter is necessary for the AIMOS KVM because it draws power through the HDMI cables, but the E-SDS has its own power supply, so it shouldn't need a powered splitter in the mix.

    Would it be possible to try ports 1-4 instead of 4-8 just to see if there's something different about those ports on the E-SDS?

    1. J@jtca2021-05-28 12:23:47.147Z

      I have switched the ports. I did get better results but not good results. The server on port 4 can be on any port and works. Two of the other servers don't work on any port. The last 2 servers will show a garbled screen.

      Based on this maybe the HDMI to VGA adapters are spotty???

      Also I have tested with and without the powered splitter. Doesn't make a difference. The powered splitter allows me to put a monitor and keyboard/mouse in that closet to use when needed so I plan to keep it for now.

      But another issue that popped up since my original post yesterday. The Voyager stopped working and needed to be power cycled to get back working. This is the 2nd time it has happened to me in the last 10 days or so. The first time I didn't think anything of it because I was testing a bunch of ways to get the setup to work. However I went a few days without touching it and finally got around to posting yesterday about my issues. When I came in this morning to do more testing the Voyager had stopped working again (it was working yesterday). When it happens the red light is solid but there is no green light and the web interface is not accessible. Only thing I have tried to fix is to power cycle the Voyager. I did check for an update this morning and there was no update available.

      So while my issue might be the video adapters, the hardware issue with the Voyager might be a cause as well???

      1. Michael Lynch @michael2021-05-28 20:01:46.690Z

        It's hard to tell if there's a hardware issue with the Voyager. It's pretty unusual for that to be the case. There are a few hundred Voyagers in the field, and I've never had a customer run into an issue where the device couldn't boot due to hardware issues. Sometimes a microSD dies, but that doesn't sound like what's happening with your device since it boots up after a reboot.

        I'm wondering if the KVM or the powered HDMI splitter are sending power through the Voyager's HDMI port and that's what's causing it to die. Does the Voyager ever die in a normal setup where it's just connected directly to a server?

        Based on this maybe the HDMI to VGA adapters are spotty???

        HDMI to VGA adapters sometimes do fail, but it'd be surprising if you got so many dud units at once.

        You have a setup that works consistently through a port and an HDMI to VGA adaptor, correct? That's helpful because you have a "known good" setup. You can test the theory of whether it's a bad HDMI to VGA adaptor by swapping out the adaptor on port 4 with one of the other adaptors (keep track of the working one though). Similarly, you can try the "good" adaptor on a port other than 4. And you can connect the "good" server to a port other than 4 with the "good" VGA adaptor. By systematically swapping out components of the good path, you can narrow down what components are causing issues.

        1. J@jtca2021-05-30 15:11:47.742Z

          I have tried swapping out the HDMI-VGA adapters and still get the same situation where only port 4 works. I tried switching just the micro-usb power cables to the adapters and that didn't make a difference.

          I did not try testing without the powered HDMI splitter. I did have an issue where when I rebooted the server on port 4 the Voyager disconnected, meaning I could no longer access the web interface. Only way I found to get the interface back was to power cycle the Voyager. Tested that twice and it happened both times. I thought the Voyager should survive a reboot??

          I will try testing without the splitter this week.

          1. Michael Lynch @michael2021-06-02 19:26:10.530Z

            I have tried swapping out the HDMI-VGA adapters and still get the same situation where only port 4 works. I tried switching just the micro-usb power cables to the adapters and that didn't make a difference.

            Okay, so it sounds like it's not HDMI-VGA adaptors. Is it something special about the KVM's port #4 or is it the server on the other end? If you switch the server currently on port 4 to port 5, what happens? Are all the PowerEdge Servers the same hardware?

            I thought the Voyager should survive a reboot??

            Voyager does generally survive a reboot, but I've occasionally seen it reach a state where it fails to pick up video again until you reboot the Voyager. It's likely that you don't have to reboot the whole Voyager, as you can probably just restart the video streaming service. There's currently no way to do this through the web interface, but you can do it if you SSH in and type

            sudo service ustreamer restart
            
            1. J@jtca2021-06-03 14:12:37.825Z

              Nothing special about port 4. I have switched that server to another port and it worked as it should. Just kept identifying it as port 4 to make it easy to keep track in this discussion.

              PowerEdge servers are not all the same hardware. Only 2 of the 5 have the same hardware. Neither of those 2 are the port 4 server.

              Thanks for into on the reboots. I will add that to my notes on the Voyager.

              1. Michael Lynch @michael2021-06-04 16:21:14.821Z

                Only 2 of the 5 have the same hardware. Neither of those 2 are the port 4 server.

                It sounds like the issue is one of the following:

                • The servers aren't compatible with the E-SDS
                • The servers aren't compatible with TinyPilot
                • The servers aren't compatible with the E-SDS + TinyPilot chain

                For the servers that aren't working through the E-SDS, does it work if you connect the Voyager directly to them (without the KVM or splitters)?

                1. J@jtca2021-06-07 12:24:36.378Z

                  I think you are right it is one of those things. I actually moved back to the IOGear KVM switch because if it wasn't going to work I like that switch better than the E-SDS.

                  I will test the Voyager directly connected to one of the servers that didn't work through the switch this week and let you know.