No internet connection
  1. Home
  2. Technical Support

No Video on Voyager 2

By Ashish Yadav @ashish9433
    2022-02-22 16:51:00.290Z

    Hi @michael

    As discussed with you, starting a separate thread. here it is the logs link -> https://logs.tinypilotkvm.com/TejfFamD

    Also, there was no change made. Infact i did ssh today prior to that it was working perfectly fine on 18th Feb. That was the last time i used it.

    Can you suggest how can we fix it? Do we need to reset of something?

    Solved in post #2, click to view
    • 7 replies
    1. Thanks for reporting this!

      That's really strange. I don't know how uStreamer would just disappear. I haven't seen an issue like that before.

      You can force TinyPilot to re-install all the necessary components by SSHing in and running this command:

      /opt/tinypilot-privileged/update && sudo reboot
      

      If that doesn't work, you can try a factory reset.

      ReplySolution
      1. AAshish Yadav @ashish9433
          2022-02-22 18:17:55.928Z

          @michael

          Thanks for the revert. I did run the update and rebooted. It did gave me an error during the update which i have attached as an image. Though it said ansible was not able to start the ustreamer service but after reboot i am able to see the video popping up.

          Any idea how we can have this addressed in future?

          1. If it happens again, let me know. I've never seen any other reports like that, so I'm not sure how your system got into that state.

            1. AAshish Yadav @ashish9433
                2022-02-22 19:12:39.219Z

                perfect, thanks! & Thanks for replying with a quick fix :)

            2. In reply tomichael:
              SSrinivas Bakki @srinivas
                2022-03-13 18:11:19.948Z

                Hi michael, same here with voyager2 . I had upstream connection errors exactly as @ashish9433 . I did update as mentioned in the post. The connection errors disappeared and upstream logs do not show any error while initializing. However when the nginx server starts upstream closes connection prematurely. Plese check the logs here: https://logs.tinypilotkvm.com/UqB0MdRx

                1. In reply tomichael:
                  SSrinivas Bakki @srinivas
                    2022-03-14 08:58:12.363Z

                    After some more testing the ustream errors disappeared but still there is NO SIGNAL. There's this only error:

                    Mar 14 08:52:02 tinypilot ustreamer[598]: -- ERROR [18.146 stream] -- Persistent device timeout (unplugged)

                    full logs: https://logs.tinypilotkvm.com/oHWxEApJ
                    Does this mean it's unable to capture the video ? I use a VGA to HDMI adapter from livetech. And it works perfectly well in other places.
                    Please help

                    1. DDiego @diego2022-03-14 17:40:07.887Z

                      Srinivas - Your issue will be worked on the new thread you opened (thank you for doing so). For reference, the new thread is: No Signal on voyager 2