No internet connection
  1. Home
  2. Technical Support

Can't access TinyPilot web interface during first setup

By @stargazer
    2022-05-30 05:03:31.250Z

    It sounds like this might be the same issue mentioned in this thread, but I'm not sure: can't connect

    Here's what I've done so far:

    1. Plugged ethernet into TP. The ethernet port currently has a flashing green light on the left, and a solid orange light on the right.
    2. Plugged in power. The red status light is on.
    3. Connected the USB data cable and the HDMI cable to the target laptop.
    4. I can't access the web interface at either https://tinypilot/, https://tinypilot.local/, or https://tinypilot.localdomain/. My target computer recognizes that it's plugged into something, because the screen has changed to mirror mode.

    If it's the same issue as in the "can't connect" thread, then to answer the question you asked there, I do have a microSD reader, so I could try to re-flash the card. Let me know if that's what you recommend.

    Solved in post #4, click to view
    • 7 replies
    1. Progress
      with handling this problem
    2. S
      @stargazer
        2022-05-30 05:05:11.884Z

        Specifically, when I try to access any of the web domain urls, I see this:

        This site can’t be reached
        Check if there is a typo in tinypilot.local.
        DNS_PROBE_FINISHED_NXDOMAIN

        1. D
          Diego @diego2022-05-30 18:10:58.110Z2022-05-30 21:38:45.142Zreplies tostargazer:

          Hello @stargazer! I'm very sorry you are having this issue. It does not look like the same issue as in the other thread you mentioned.

          Before you attempt a factory reset, please verify the following:

          • The ethernet cable from the TinyPilot goes to your router and there is a link light on both ends.
          • The computer you are using to connect to the TinyPilot web interface is connected to the same network the TinyPilot is connected to (i.e. they are both connected to the same router).
          • If possible, try to log into your router and verify there is an entry for the TinyPilot, in the DHCP table. It should show the IP address the router assigned to the TinyPilot. If there is such entry for the TinyPilot, try to connect to that IP address, instead of using the hostname.
          ReplySolution
          1. S
            @stargazer
              2022-05-30 21:36:59.826Zreplies todiego:

              Ah, good catch - but now I'm running into a different issue. (I recently set up a mesh network, so the computer I was using to access tinypilot was on my new network, but the ethernet cable is connected to the old network.)

              Now when I visit tinypilot or tinypilot.local, I get the expected "Your connection is not private" message, but when I click the Advanced button, I get this message:

              tinypilot normally uses encryption to protect your information. When Chrome tried to connect to tinypilot this time, the website sent back unusual and incorrect credentials. This may happen when an attacker is trying to pretend to be tinypilot, or a Wi-Fi sign-in screen has interrupted the connection. Your information is still secure because Chrome stopped the connection before any data was exchanged.

              You cannot visit tinypilot right now because the website sent scrambled credentials that Chrome cannot process. Network errors and attacks are usually temporary, so this page will probably work later.

              I've waited ~8 minutes. I'll keep trying, but since the setup instructions say TP should take up to 5 minutes, I wonder if something's wrong.

              1. S
                @stargazer
                  2022-05-30 21:41:36.742Zreplies todiego:

                  And to answer your 3rd question, yes, when I log into my router, I see a TP entry that says "Allocation: dhcp".

                  1. S
                    @stargazer
                      2022-05-30 21:49:38.175Z

                      Interesting - I saw this thread: Newbie Problems / Questions

                      And found that I was also able to get in via Safari. I'll follow the instructions re: fixing the privacy/cert issue, and see if that helps me use Chrome afterward.

                      1. D
                        Diego @diego2022-05-30 21:57:35.882Zreplies tostargazer:

                        The Chrome warning should be a little different though, and should let you proceed after clicking "Advanced", but if that's not the case, then please yes, do follow the instructions in our FAQ article: How do I fix browser privacy errors?

                        1. S
                          @stargazer
                            2022-05-30 22:13:34.560Zreplies todiego:

                            (Just to close the loop on this: Now that I have the cert installed/trusted locally, I can access the web interface on Chrome.)

                            1. D@diego marked this topic as Done 2022-05-30 23:49:54.797Z.