No internet connection

Welcome to the TinyPilot community!

You can ask questions, make feature requests, or share neat things you've done with your TinyPilot.

Topics, recently active firstCategoryUsers / AssignedRepliesActivity
Welcome to the TinyPilot Forum
This is a place for TinyPilot users to;
    GeneralKR42024-02-16 19:43:49.346Z
    tinypilot nvr integration
    dear group, i bought tinypilot pro, in order to control my two nvrs in server room( ground floor) from my office ( first floor ) via our local lan . i bought all hardware mentioned in the video View on YouTube as of now i cannot use mouse movements o...
      GeneralJB92024-05-25 20:31:48.680Z
      How to save configuration
      Since there seems to be a lot of questions here where the answer is "I sounds like you have a corrupted OS," is there a way to save the configuration so it can be restored later?
        Technical SupportSCS/C22024-05-25 10:39:11.719Z
        Please add a way to cancel a virtual media upload
        I'm preparing a TinyKVM and am working on uploading the images that we think we'll need in the first 90 days locally from my desk. Some of these images are 10-16GB (we're using a 128GB USB Flash Drive instead of the microSD). I made the mistake today...
          IdeasSC/C12024-05-25 02:37:53.679Z
          Video Quality Over Internet
          When I use TP on my local network the video is perfect and looks exactly like the screen on the laptop I have connected. When I go away from home, I use TailScale, and the video quality goes down. What solution gives the absolute best experience as i...
            Technical SupportFC/C12024-05-25 02:33:44.864Z
            how do i create a backup of my tinypilot? or install packages to do so?
            for instance sysupgrade -c -k -b /tmp/tinypilot.tar.gz doesn't work, there is no package installed for sysupgrade, how do I back it up other than yanking out the sd card and creating a copy via GUI? Thanks
              Technical SupportMSC82024-05-25 02:28:31.464Z
              able to acess tinypilot.localadmin but not via hostname
              Hello I just re-imaged my tinypilot as it was not accessible. I renamed it hostname as previous one (tinypilot-1) which was the name I had prior to it stopped working The reimaginghas been done perfectly However it is accessible via tinypilot.local b...
                Technical SupportS02024-05-25 02:22:17.539Z
                "This root certificate is not trusted"
                Mac OS Sonoma 14.3 Chrome Version 124.0.6367.91 (Official Build) (arm64) I tried deleting and re-adding without any change. Howdy! I have a new TinyPilot Pro I'm configuring. When I follow the FAQ entry for installing the cert, I get the following er...
                  Technical SupportC/32024-05-24 11:33:50.690Z
                  New TinyPilot. Can't login
                  Hi there. Second TinyPilot I purchased couple of weeks ago is not working, I can't access web interface. I have changed host name on my first TinyPilot (both are on the same network). Rebooted both. I verified hostname for 1st TP has changed (alpha, ...
                    Technical SupportI/72024-05-22 14:14:30.529Z
                    Technical Issue with TinyPilot Voyager 2a
                    Hi there, I've been using the TinyPilot Voyager 2a for two weeks without any problems. However, after shutting it down last Friday, it's not working properly upon restarting on Monday. While SSH access is fine, the web interface shows that TinyPilot ...
                      Technical SupportDC/C52024-05-21 22:44:55.051Z
                      Explain icons...
                      Media Requested with Windows 10 Install
                      It is certain I am doing something wrong. I downloaded the Windows 10 Media Creation Tool. Created an ISO, uploaded and mounted it to install on a machine. The machine boots from the virtual mounted media (USB or CD-ROM do not seem to matter). Howeve...
                        Technical SupportWLRC/C102024-05-21 22:41:11.575Z
                        No video signal (or garabled colors) after reboot
                        Hello. I just recently added a TinyPilot to a server to be able to send commands directly after reboot. This particular system has a finicky RAID controller and occasionally it'll need user interaction to continue to boot. Unfortunately, I'm in the s...
                          Technical SupportPC/C12024-05-21 21:32:44.533Z
                          Windows 11 - missing USB Storage
                          Hello, Windows 11 based installations can't see USB Storage, so installation from Virtual Media is not possible. Is there any workaround ? Thanks.
                            Technical SupportVL52024-05-21 11:01:00.858Z
                            Audio Streaming Support
                            I just purchased the most recent TinyPilot Pro and updated to version 2.6.3 but I still can't stream audio I followed the troubleshooting guide, but I still can't get it to work in the latest Chrome browser with sound enabled How else can I troublesh...
                              Technical SupportP/12024-05-21 10:50:28.919Z
                              Error installing
                              I'm trying to install the software on a brand-new configured Raspberry Pi 4 with: curl \ --silent \ --show-error \ https://raw.githubusercontent.com/tiny-pilot/tinypilot/master/get-tinypilot.sh | \ bash - && \ sudo reboot ...but I get th...
                                Technical SupportSC/C12024-05-20 16:30:45.970Z
                                Display capture issue
                                Hi Guys, I'm using an RPi4 with a USB HDMI capture card. Every time I reboot the RPi4, the screen cannot capture the target machine, and it only shows the color bar display. To resolve this, I need to reboot my target machine before it will display t...
                                  Technical SupportJC/C42024-05-20 16:19:37.181Z
                                  Getting error trying to load windows 11 from ISO
                                  Trying to load windows 11 iso in virtual media set in Flash mode. Shows up ad USB CDROM: When I try to to boot to it I get this:
                                    Technical SupportU12024-05-20 15:29:40.623Z
                                    Two cursor moving from my personal laptop when try to use my targeted computer
                                    I connected my tiny pilot and for my targeted computer to my personal computer and when I try to use the computer from my personal computer I see two cursor moving I click on desire tab and it get click on another tab that I do not want
                                      Technical SupportM/52024-05-20 14:33:21.018Z
                                      Can't connect Tinypilot
                                      Hi, I've used the Tinypilot so far and it worked fine. Yesterday, I bought a new one and I tried to change the hostname of it. It showed me an error but now for some reason both of Tinypilots are not working. Can you please help me to resolve this is...
                                        Technical SupportJ2C/C42024-05-16 22:54:26.165Z
                                        How do we know when it's safe to unplug power?
                                        When shutting down the TinyPilot itself (Voyager2a PoE), I notice the fans stay on and spinning eternally. How do I know when it's safe to unplug the unit? I have already corrupted my SDcard once apparently from disconnecting too early. Is there any ...
                                          GeneralLC/C112024-05-16 22:45:06.457Z
                                          Tinypliot is not working
                                          Hi, I am getting white screen. https://logs.tinypilotkvm.com/yc0VrUEL
                                            Technical SupportTCT/C52024-05-16 16:34:43.763Z
                                            No Video after PC restart
                                            After receiving the TinyPilot 2a got it installed and all worked perfectly. I removed the existing monitor, keyboard and mouse and replaced with the cables connecting to the TinyPilot. Again it worked perfectly. I am using the HDMI to VGA purchased w...
                                              Technical SupportN/52024-05-16 11:25:41.184Z
                                              Fan turning off and tinypilot "/opt/tinypilot/venv/bin/python: no such file or directory" error
                                              On one of our new tinypilots we've had a few weird issues that may be unrelated, after setting it up and having it work for a few weeks, we stopped being able to connect to the tinypilot and received the attached errors. We attempted re-imaging the S...
                                                Technical SupportA/12024-05-14 11:58:37.731Z
                                                Updating Failing and video stream stopped working after i tried
                                                Hi, I'm trying to update my Voyager 1 and it keeps failing with the following message: The update failed: Command '['sudo', '/opt/tinypilot-privileged/update']' returned non-zero exit status 2. After my first attempt of installing the update but fail...
                                                  Technical SupportT/72024-05-10 18:58:09.769Z
                                                  New TinyPilot Power module, USB is maybe loose?
                                                  Hey, I just got a new TinyPilot and am attempting to use it with a new micro USB cable. At first it did nothing, then I realized if I apply pressure a certain direction on the micro USB power socket, the LED comes on. if pressure (even gravity) is ap...
                                                    Technical SupportJ/52024-05-10 18:57:28.166Z
                                                    Using WinPE to Image via a WIM
                                                    Good afternoon! My company purchased a TinyPilot for testing. We are looking at deploying these to machines in our customer's production environments. (Minimum of 2 TinyPilots per site, hundreds of sites) I would like to have the option for the USB v...
                                                      Technical SupportP/32024-05-10 18:48:28.665Z
                                                      tinypilot systemd unit will not start successfully after rebooting in USB Virtual Media mode
                                                      Voyager 2a version 2.6.3 I just realized I cannot reboot successfully after enabling USB Virtual Media mode. I followed the steps, and everything "works". I can see the USB drive (/dev/sda1) mounted to /media/tinypilot-mass-storage. Here's some outpu...
                                                        GeneralLC/C82024-05-10 08:54:12.501Z
                                                        Technical SupportM/22024-05-10 08:40:03.611Z
                                                        microSD image
                                                        Hi Michael, I suspect a corrupted image due to user error. Can I request the latest TinyPilot microSD image?
                                                          General112024-05-09 18:37:50.380Z
                                                          Technical SupportCY/C122024-05-09 11:52:23.901Z
                                                          H264 stopped working after update
                                                          I think H264 stopped working after I updated my tinypilot. Here is the log: https://logs.tinypilotkvm.com/8ZozEYHl
                                                            Technical SupportM/12024-05-08 12:01:58.668Z
                                                            Tiny Pilot not running
                                                            Hello, Have a TinyPilot voager that for some reason will not let me connect (i have previously been able to connect to it). When I go to the browser to try and connect, I get the message "Tiny Pilot is not running". I was able to ssh into the device ...
                                                              Technical SupportT/52024-05-07 11:22:44.406Z
                                                              The device transmits neither video no keyboard
                                                              We are able to access the tinypilot from the browser. However, it does not do what it should - there is no video, no keyboard translation. The device is connected to a VGA port of the dell R410 server with the HDMI- VGA adapter and keyboard uses the ...
                                                                Technical SupportB/42024-05-07 11:16:24.832Z
                                                                Raspberry Pi TinyPilot KVM mouse and keyboard issue
                                                                Hello, I have had this issue in the past and it turned out to be a USB-C cable I was using with the Tinypilot Power connector. After ordering a better cable, I have had no issues. I took t he system down to relocate and now that I have reconnected, I...
                                                                  Technical SupportR/32024-05-07 10:34:33.588Z
                                                                  The unit is not working. Need to return
                                                                  How do we return the unit which is not working at all?
                                                                    Technical SupportB/12024-05-06 11:26:51.576Z
                                                                    Technical Support/42024-05-06 11:10:29.703Z
                                                                    Issue while connecting to tiny-pilot
                                                                    I bought a new tiny pilot. I am unable to connect to my target laptop using my another personal laptop. I tried to access all the url's provided in the instructions. But still I am unable to connect. Can you help me provide os settings for sd card pr...
                                                                      Technical SupportM2/72024-05-01 11:28:27.533Z
                                                                      local control - hdmi splitter
                                                                      Hi Im looking for a solution to control the local computer and also from the web browser. Has any one tried something similar? Computer -> hdmi splitter 1. Tiny pilot 2. Local monitor And how about using DisplayPort?
                                                                        Technical SupportS/32024-04-30 10:53:10.539Z
                                                                        Tinypilot can't access internet during intial setup
                                                                        Hello, After reimaging the tiny pilot, turning on ssh, and ssh'ing into the device I try to run curl -fsSL https://tailscale.com/install.sh | sh && \ sudo tailscale up and get curl: (6) Could not resolve host: tailscale.com -bash: : command not found...
                                                                          Technical SupportNN22024-04-30 09:34:02.585Z
                                                                          TinyPilot with 502 Error
                                                                          Hello - I have a Voyager 2a TinyPilot. While trying to access it this morning, I received a 502 Error: "TinyPilot is Not Running." I tried Solution 1: "Restart the TinyPilot service" and Solution 2: "Restart your TinyPilot" without luck. I have not t...
                                                                            Technical SupportN/42024-04-29 11:08:41.984Z
                                                                            502 error on Voyager 2a, no physical access to device
                                                                            Hello, I have a Voyager 2a running Tinypilot version 2.6.3 that is giving me the "TinyPilot is not Running" browser page. My logfile upload can be found at https://logs.tinypilotkvm.com/Bh2nJXvX I set up this device at my home office last week, and i...
                                                                              Technical SupportG/32024-04-25 18:08:48.833Z