No internet connection

Welcome to the TinyPilot community!

You can ask questions, make feature requests, or share neat things you've done with your TinyPilot.

Topics, recently active firstCategoryUsersRepliesActivity
Weird bios issue with HP Z640 Workstation
I'm having a weird issue with the BIOS on an HP Z640 Workstation. Everytime I try to change a setting on the bios, the tinypilot screen freezes and/or the keyboard stop working. I can't even issue a crtl+alt+del to reboot, I have to power the PC off ...
    Technical SupportRP52023-02-13 19:50:48.906Z
    Not getting screen image
    Hi I am not getting screen image on my client laptop. It seems all keyboard commands are being responded to ok by the server laptop but I am not seeing the screen on my client laptop. I have changed it with a working tinypilot and everything seems to...
      Technical SupportSCS42023-02-13 15:07:43.949Z
      Update Failed
      I am facing latency issues, and would love to get the latest update to version 2.5.0. But when I try to update it, I get a failed to update error. These are my logs:
        Technical Support1C42023-02-13 12:54:36.646Z
        Online demo
        Is there anyway to get/see/obtain an inline demo ?
          Technical SupportP12023-02-13 12:34:00.438Z
          Certificate Not recognized
          Hello! Just got my TinyPilot and everything works great, except I can't get the cert to work as expected. I follow all directions for installing the cert on Windows (including placing it in the Trusted Root Certification Authorities), but I still see...
            Technical SupportAC32023-02-12 20:08:15.332Z
            stability of sd card?
            Just found the TinyPilot. Looks like just what I am searching for. I do have one concern, the long term stability of using an SD card for the OS. I say this because about 8 years ago I put a Pi (running Raspian) in use to do some snmp samples. It ran...
              GeneralLC12023-02-12 19:35:11.058Z
              Hostname change with https
              Hi, I recently changed the hostname. After reboot, the web page will no longer come up presumably due to a certificate issue. I have http disabled. How can I enable http via the cli? I really don’t need https anymore because I now use an ssh tunnel t...
                Technical SupportV42023-02-10 12:15:50.392Z
                502 Bad Gateway
                We purchased a Voyager and it's at a remote site. After a failed update we were met with this when attempting to log into it: "502 Bad Gateway". I've had someone manually power cycle the device and still seeing the same error. I can see it on the net...
                  Technical SupportJCJ62023-02-09 16:49:33.771Z
                  Use tailscale keyboard to double click
                  I’m using tail scale to view my Remote Desktop using my phone. I can see the pointer but I’m wondering if there is a keyboard stroke that i could use to double click since i can’t double click using my phone screen
                    Technical SupportJ12023-02-09 12:58:49.769Z
                    Not a problem but a question: what's the difference between Voyager 2a and 2?
                    What's the difference between TinyPilot Voyager 2a and TinyPilot Voyager 2? I tried Googling and looking for any blog post announcement as well as reviewed the product page, but didn't see any comparisons or announced changes in 2a relative to 2. Thanks
                      Technical SupportTC12023-02-08 22:49:17.399Z
                      Explain icons...
                      No signal with VGA adaptor - keyboard and mouse works fine.
                      Hi, I have just received the "tiny pilot" together with the VGA to HDMI adaptor. I keep getting "NO SIGNAL" on a black background when connecting. Keyboard and mouse works fine. I experience the same with 3 different VGA outputs/sources. I have succe...
                        Technical SupportKN62023-02-08 12:40:38.933Z
                        Can't send keyboard-mouse input to target machine
                        Current machine = Macbook Pro Target machine = the machine I want to remotely control, a desktop PC. I have set-up TinyPilot with my target machine and can access it via IP address in a web browser using TailScale. Here's what I see:
                          Technical SupportT32023-02-07 12:05:35.970Z
                          Update failed from 2.4.0 to 2.5.0
                          I can't update the tinypilot The update failed: Command '['sudo', '/opt/tinypilot-privileged/scripts/update']' returned non-zero exit status 2. Please advise, Alexander
                            Technical SupportAC32023-02-06 22:30:46.381Z
                            MSI Bios is completely unusable
                            When booting into the bios on an MSI X570-A PRO, the interface essentially becomes completely unusable. I managed to get it into the advanced -> config mode using the keyboard, but then even that became unresponsive quickly. This is the first time us...
                              Technical SupportCMT72023-02-06 20:19:48.008Z
                              can't connect
                              I have just installed tinypilot. It i visible on the router, but I can't connect via https://tinypilot.local or https://tinypilot If there is no way to connect to it, then I can't begin to troubleshoot
                                GeneralST182023-02-06 19:20:07.905Z
                                Refund Request
                                Hi, I have not been able to get the TinyPilot Voyager 2 PoE up and working. For $474.81, I hoped for a seamless solution. Forum-based support has not been responsive enough and unfortunately, I don't have much time to wrestle with this since I need t...
                                  Technical SupportTT42023-02-06 17:37:26.377Z
                                  Audio streaming
                                  Hello, I installed the tinypilot and so far it's been great. I use it to remote control a work laptop at the office from home. I was wondering if there is a way to stream the audio/microphone so that I would be able to also take calls from the work l...
                                    GeneralFVTMC122023-02-06 17:20:22.415Z
                                    enable SSH
                                    Hi, my SSH access was disabled and unable to enable back. may i know how to enable it? thanks!
                                      Technical SupportOC52023-02-06 17:14:10.375Z
                                      H.264 fail
                                      I'm getting this error when trying to switch to H.264. I've tried disabling and re-enabling it then rebooting, but same issue. "TinyPilot failed to stream video output from your target device using H.264 compression." How can I fix this? Logs link: h...
                                        Technical SupportS112023-02-06 15:16:33.146Z
                                        No mouse when connecting TinyPilot via AIMOS KVM
                                        When my TinyPilot is connected directly to a PC it works fine, but if I try to connect it via an AIMOS KVM as described in the KVM compatibility list (i.e. combined with HDMI splitter) the keyboard works but the mouse does not, the pointer jiggles ra...
                                          Technical SupportDT162023-02-06 12:38:53.312Z
                                          2.4.1 H264
                                          Hello there :) I see that experimental support was added for H264 streaming, but I don't see any way to enable it in the GUI. I'm guessing it's done over SSH and if so, how? Thanks!
                                            Technical SupportNLDS132023-02-04 08:37:22.087Z
                                            Can we use Tiny Pilot for IPAD Remote Control ?
                                            Hello, If i connect my Ipad with USB C Hub with HDMI, Keyboard & Mouse Output and connect same to Tiny Pilot it will work ? My main purpose is to remote control and monitor of IPAD Installed at remote location. Thankx in advance .. Regards, Vipul
                                              Technical SupportP2BC92023-02-02 17:51:12.730Z
                                              Alt-Tab leaves remote system as if Alt is still pressed
                                              First I love being able to work on my 2nd machine within a window on my primary desktop. Thank you. [edit: I am running in Chrome's "create shortcut" app mode, if that matters.] But when I use Alt-Tab (yes, I am an long-time keyboard user) to switch ...
                                                Technical SupportFRA92023-02-02 17:31:25.686Z
                                                Tiny Pilot to Raritan KVM
                                                I just purchased a TinyPilot Voyager 2 in hopes of using it with our Raritan Dominion KXII.. I had no issue setting the unit up. I did purchase the VGA to HDMI adapter and plugged that into the Raritan KVM. I can see the main menu and the keyboard an...
                                                  Technical SupportC52023-02-02 17:17:12.982Z
                                                  Error when connecting in browser
                                                  Using Tinypilot voyager with Tailscale on ethernet cable over IP. Was working before that, but was having internet issues. Any ideas what happened or how to fix? Getting before the login page should be popuping. instead get this: {"code":null,"messag...
                                                    Technical SupportTC82023-02-02 02:24:26.236Z
                                                    Keyboard not working
                                                    Hello Guys, We've bought TiniPilot2 for about 6 months ago, but we never were satisfied. The keyboard simply crashes in BIOS, in different Linux systems like Centos 7, Almalinux 8 and others. Also a lot of video glitches. I don't understand why so, b...
                                                      Technical SupportAC32023-02-02 01:53:06.058Z
                                                      Can I use the tinypilot as a wifi hotspot?
                                                      i dont have wifi enabled yet, but im curious, as opposed to connecting to the tinypilot's wifi ssd (presumably)is there a way to feed an ethernet cable from a router with internet, or a computer, into tinypilot, and have my tinypilot , which has tail...
                                                        Technical SupportMC32023-02-02 01:42:44.210Z
                                                        Using tinypilot voyager 2 with multiple computers
                                                        I need to connect 3 computers and use them remotely. Do I need to get 3 Voyager 2 units, or can I use one unit to control each of the three computers from my tablet?
                                                          Technical SupportZC72023-02-02 01:36:14.804Z
                                                          Adding keyboard shortcuts to menu
                                                          I see a menu option on the Voyager 2 for Keyboard shortcuts and all it has is CTRL-ALT-DEL. I want to add ALT-TAB to it, as well as others that I use. How can I do this?
                                                            Technical SupportZ32023-01-31 15:19:38.123Z
                                                            Obtaining a screenshot using the internal API
                                                            I'm a student writing custom software to automate a host machine (also referred to as the "target") through the TinyPilot Voyager 2 using the exposed APIs defined in (for RESTful calls) and (for WebSocket connections). For the cu...
                                                              Technical SupportA2J62023-01-30 23:05:52.414Z
                                                              tinypilot running out space because of log files
                                                              When I tried to update tinypilot today, I discovered that it had run out of space. Investigation showed that /var/log/syslog and /var/log/kern.log were about 7 gigs each. The reason probably is that I only run tinypilot on a need basis, i.e. I don't ...
                                                                Technical SupportS2C12023-01-29 03:33:06.550Z
                                                                Technical SupportM2C72023-01-29 01:00:50.767Z
                                                                Changed RSA certs for ECC and modified NGINX config, will this revert?
                                                                I installed our first Tinypilot today and added our custom SSL certs. When trying to connect to NGINX we realized there was a public-key signature algorithm mismatch so the client/server couldn't agree on a cipher and the SSL handshake failed. It was...
                                                                  Technical SupportS2CS222023-01-27 15:01:05.775Z
                                                                  Error: Malformed API response, content type must be JSON. Response status: 504
                                                                  i try to turn on ssh on the security page in tinypilot, it shows disconnected after a few seconds (red button on bottom left), but I get this error in a pop up. Refreshing shows ssh still disabled. how to fix this? Also any commands, once I do ssh, t...
                                                                    Technical SupportM12023-01-27 12:32:56.439Z
                                                                    update from 2.5.0 to 2.5.2 failed
                                                                    The update from 2.5.0 to 2.5.2 fails. The update failed: Command '['sudo', '/opt/tinypilot-privileged/update']' returned non-zero exit status 100. The issue appears to be here: dpkg: unrecoverable fatal error, aborting: reading statoverride file '/v...
                                                                      Technical SupportS52023-01-27 12:23:01.321Z
                                                                      No mouse or keyboard input
                                                                      No mouse or keyboard input. Confirmed using USB-C (Data) from TinyPilot to USB-A on device. Updated to latest version 2.5.2 Logs - lsusb Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 002 Dev...
                                                                        Technical SupportHC32023-01-26 14:30:00.177Z
                                                                        Web upgrade 2.5.0 to 2.5.2, then no response on network
                                                                        Use the web based upgrade and watched all the messages. When completed got a message something like "Can not connect. Please power off and on and try again" I power cycled and still no web access or response to ping. Please advise how to proceed. Tha...
                                                                          Technical SupportMC22023-01-26 12:36:57.737Z
                                                                          Tiny Pilot Access from mobile device
                                                                          Hello, I was able to get my tinypilot Voyager 2 v2 set up, and calibrated the remote access using the tailscale client. Great functionality and when accessing from my PC I have no complaints! I have not tested off site, but I was able to connect from...
                                                                            Technical SupportR12023-01-24 15:51:25.689Z
                                                                            Keyboard and mouse don't work anymore
                                                                            Hello, I've purchased the Voyager 2 a few months ago (July) and it's been working fine the few times I've had to use it, but recently I've noticed that my keyboard and mouse don't work anymore. I've checked the logs and I get the standard "Is USB cab...
                                                                              Technical SupportK252023-01-23 12:02:30.165Z
                                                                              usb-gadget keeps exiting
                                                                              I have a TinyPilot Voyager 2 and it seemed to be working fine for a while. One day, it apparently stopped sending USB input. I tried running: echo -ne "\0\0\0\0\0\0\0\0" > /dev/hidg0 and got an error saying: echo: write error: Cannot send after tran...
                                                                                Technical SupportP2C82023-01-23 01:18:20.659Z